Оставить только необходимые пакеты

В попытке узнать больше об Ubuntu и ее пакеты, я хочу, чтобы удалить все не-необходимые пакеты, так что я могу установить то, что мне нужно, когда я нуждаюсь в них и знают, что делают.

Я с помощью команды команды dpkg --понятно-выборы и apt-получить программу dselect-обновления для этого. Я также немного изменить выбор, установив кв. с libstdc++6 (в связи с апта) установить-Инфо (за счет грэп) , чтобы установить вновь (как-то с dpkg думает, что они не являются существенными, но apt-получить жалуется).

Это нормально, или это плохо? Если это нормально, то что мне делать с большим списком пакетов с "деинсталляции" статус в dpkg?

Дополнительное примечание, Я делаю это на шаблоны, так что я не имеем никакого контроля над первоначально установленных пакетов.

+607
Franz Stoneking 13 авг. 2018 г., 10:37:00
21 ответов

Просто нажмите сочетание клавиш Ctrl+АЛТ+т на клавиатуре, чтобы открыть терминал.

Когда она открывается, выполните команды ниже.

с PulseAudio -к делает то же, что команду killall PulseAudio так && PulseAudio так

+946
Robin Nemeth 03 февр. '09 в 4:24

Ваш D865GSA материнской платы была прекращена корпорацией Intel.

Начиная с Ubuntu поставляется с большим количеством вне---коробка драйверы и универсальные драйверы; их не нужно устанавливать драйверы как таковые.
Вы много хотите устанавливать драйвера, только если некоторые из ваших компонентов материнской платы не работает или не обнаруживается.

Вы можете иметь ваша материнская плата драйверы от Intel поддерживает страницы, под
Продукция, снятая с производства > для настольных ПК > 865 чипсет семьи > настольные настольные 865GSA

Вот Intel поддерживает ссылке специально для вашей материнской платы
к сожалению, процессоры Intel, имеющие большинство в Windows драйверов, так вы можете выбрать "независимые категории ОС".

Если вы не испытываете какие-либо проблемы, то вам не нужно устанавливать каких-либо драйверов. Убунту поддерживает большинство старого нового оборудования.

+912
er3303 27 янв. 2011 г., 15:08:18
Обеспечение качества (ОК) относится к деятельности, осуществляемой в системе, так что требования к качеству продукта или услуги будет выполнено.
+868
Saiteja Kuruva 7 авг. 2014 г., 0:22:36

Я установил Ubuntu 12.04.2 на моей системе (Делл XPS L702x). Моя система имеет NVIDIA Optimus и я не в состоянии установить Оптимус для того, чтобы избежать шумный вентилятор и другие вещи, как очень короткий срок службы батареи.

Я побежал команду lspci -ВМК | команда grep -а 8-Б 2 VGA и для того, чтобы увидеть, какие драйверы используются для оборудования, результат команды состоит в следующем:

Прибор: 00:02.0
Класс: совместимый контроллер VGA и 
Поставщик: Корпорация Intel
Устройство: 2-го поколения Core семейство процессоров интегрированный графический контроллер
SVendor: Делл
SDevice: Устройство 0571
Рэв: 09
Водитель: i915
Модуль: i915

--

Устройство: 01:00.0
Класс: совместимый контроллер VGA и 
Поставщик: компания NVIDIA 
Устройство: устройство 124d
SVendor: Делл
SDevice: Устройство 0571
Рэв: А1
Драйвера: для NVIDIA
Модуль: nvidia_current_updates
Модуль: модерн

Я следовал инструкции на Убунту Вики помощь в установке Оптимус, но когда я запускаю команду sudo apt-получить установку Шмель Шмель-видеокарты NVIDIA для Linux-заголовков-универсальные ЛТС-дискретные, Я получаю следующее сообщение об ошибке:

Следующие пакеты имеют неудовлетворенные зависимости:
 Шмель-видеокарты NVIDIA : зависит: от Nvidia-Current, но он не будет установлен
Е: не удалось исправить ошибки, у вас прошла сломанные пакеты.

После выполнения инструкция в это Nvidia серии GeForce с технологией Optimus технологий, поддерживаемых Ubuntu? вопрос, казалось, была решена, но теперь я постоянно получаю внутреннюю ошибку, система отчета об ошибках, мне удалось получить следующую информацию: ExecutablePath - /usr/share/apport/apport-gpu-error-intel.py Пакет - пакет xserver-xorg, с-видео-интел (не установлен) ProblemType - Аварии и т. д... Мне нужно установить пакет xserver-xorg из-Видо-Интел ? Можете вы пожалуйста помочь мне? спасибо!

следует Новый вывод результата команд lspci -ВМК | грэп -а 8-Б 2 VGA и Прибор: 00:02.0 Класс: совместимый контроллер VGA и Поставщик: Корпорация Intel Устройство: 2-го поколения Core семейство процессоров интегрированный графический контроллер SVendor: Делл SDevice: Устройство 0571 Рэв: 09 Водитель: i915 Модуль: i915

--

Устройство: 01:00.0 Класс: совместимый контроллер VGA и Поставщик: компания NVIDIA Устройство: устройство 124d Рэв: ФФ ProgIf: ФФ

Устройство: 02:00.0 Класс: мультимедийный контроллер Вендор: Philips Полупроводники

+809
user37069 18 февр. 2014 г., 4:50:54

Реплика: Я хотел изменить свой ответ, но этот инструмент заслуживает отдельного ответа для дальнейшего использования.

Для пользователей, которые имеют метаданные в мп3 (что часто бывает, когда музыку покупали на законных основаниях), можно переименовывать файлы на основе метаданных.

Есть отличный пакет, который делает переименование на основе метаданных для музыки и изображений: pyRenamer. Можно установить его с помощью команды sudo apt-получить установку pyrenamer.

По сути, он использует регулярные выражения и метаданные, переименовывать файлы. Таким образом, вы можете переименовать файлы, чтобы включить информацию в метаданные. Вот скриншот.

A screenshot of PyRenamer

Это также работает для изображений.

Источники:

+787
Mauri Smith 15 февр. 2018 г., 7:13:42

Я искал и читал в Интернете, а также на askubuntu.

Я использую Ubuntu 11.04 и вопрос Мой или вещь, которую я хочу достичь-это эффективное использование обоих соединений и тем самым повышая свою просмотра и скоростью загрузки.

Я хочу, чтобы моя система, чтобы решить, какой пакет должен маршрутизироваться через какой интерфейс. Я хочу знать, если это возможно.

Например, можно ли маршрут альтернативные пакеты по два интерфейса ?

Пожалуйста, дайте мне знать любой интернет-ресурс или если мне придется вставить любой код в сетевые драйверы и т. д. ?

+752
Wojciech Bednarski 22 нояб. 2017 г., 3:22:46

Тонкость в конструкции из окна запуска - единство 3D оправдывает свое название с более темной тени "3D" эффект, тогда как единство 2Д легче и имеет "2Д" плоский эффект.

Единство 3D enter image description here Единство 2Д enter image description here

+716
user8737 14 окт. 2018 г., 13:26:40

Я не верю, что вы можете использовать шестнадцатеричные цветовые коды с ЗШ, или даже с любой другой оболочкой. Насколько мне известно, стандартных терминалов Linux может отображать только некоторые предопределенные цвета. Имея это в виду, я сомневаюсь, что шестнадцатеричные цветовые коды были закодированы в ЗШ, или даже может быть, поскольку это заставит вашего терминала/телетайп для использования нестандартных цветов, некоторые из которых она не может иметь возможность использовать.

+685
Aniketh Jain 6 дек. 2011 г., 4:39:57

У меня был немецкий, так как мой основной язык около года назад. Позже я изменил его на английский. Большинство элементов системы приняты изменения.

Заметным исключением являются описания пакетов, которые остаются в Германии для некоторых пакетов.

Вы можете видеть на изображении (АПТ-кэша и программного обеспечения-центр), что, хотя некоторые описания на английском, некоторые остались в Германии. Итак, вопрос: как сбросить это? Я думаю, что есть где-то тайник описание, что должно быть сказано, что он должен обновлять все описания?

screenshots of apt-cache and software-center

Редактировать: как просили: выход некоторых язык команд:

$ кот /и т. д./По умолчанию/язык
Ланг="язык.В UTF-8"

$ АПТ-конфиг дампа | грэп Ланг
Приобрести::Языки "";
Приобрести::языки:: "сайт";
Приобрести::языки:: "де";
Приобрести::языки:: "Ан";
Приобрести::языки:: "нет";

$ язык
Ланг=в ru_RU.В UTF-8
Языка=En
Языкового="в ru_RU.В UTF-8"
Lc_numeric языкового="в ru_RU.В UTF-8"
У="в ru_RU.В UTF-8"
Категории lc_collate="в ru_RU.В UTF-8"
LC_MONETARY="в ru_RU.В UTF-8"
Для категории lc_messages="в ru_RU.В UTF-8"
LC_PAPER="в ru_RU.В UTF-8"
LC_NAME="в ru_RU.В UTF-8"
LC_ADDRESS="в ru_RU.В UTF-8"
LC_TELEPHONE="в ru_RU.В UTF-8"
LC_MEASUREMENT="в ru_RU.В UTF-8"
LC_IDENTIFICATION="в ru_RU.В UTF-8"
Значение lc_all=

Как примечание: Я не уверен, что каждая запись означает, но некоторые из в ru_RU.Кодировка UTF-8, вероятно, хорошо, поскольку я не хочу, чтобы бумаги-размеры, денежное, времени, и т. д. в стандартный немецкий формат.

+672
Gerd Klima 6 февр. 2019 г., 20:53:10

Я использую Ubuntu на HP павильон G6 ноутбука, но моя видеокарта видеокарты семейства Intel HD-это набор всегда стандартный и не работает лучше. При сворачивании любого приложения Windows, в моем случае Ubuntu 12.04 очертания окно остается на экране и даже это не дает мне возможность изменить DOC на левой стороне. Пожалуйста, помогите мне я установил Меса-утилиты и обновил систему

Даже делал настройки GRUB с nomodeset, но не знаете настройках графики жратвы семейства Intel HD-качестве (Sandybridge).

+651
Domenik VanBuskirk 23 авг. 2017 г., 17:40:26

У меня по NFS файл, где я положил все мои файлы (сетевые хранилища) У меня также есть регулярное резервное копирование, которое копирует файл NFS доли в локальную папку Теперь, когда я запускаю файл через тире система находит как в NFS общий файл и в папку резервного копирования, как отключить папку резервного копирования?

+568
kevin mungai 9 апр. 2017 г., 10:58:21

Я считаю, что вы должны сделать 256colors работать, прежде чем он будет отображаться правильно.

  1. судо в Vim ~/.Xdefaults и .xsession теперь .vimrc

  2. касания .vimrc и добавить это:

    установить срок=экран-256color
    набор t_Co=256
    установить фон=темный
    

    (Вот что я сделал, пожалуйста, имейте в виду, что я новичок в этом и просто от того, что я помню. Мне потребовалось несколько дней исследования).

    если $COLORTERM == "гном-терминал", а затем установить t_Co=256 за endif
    

    Внутри .Xdefaults и: настройки: -цвет

    Затем перейдите к следующей строке и в xterm*termName: в xterm-256color

    Что должен делать это. Эхо $срок должны сказать в xterm-256color и выход цвета должен возвратить 256.

+470
genk 4 нояб. 2018 г., 14:17:54

Похоже, что это просто игра и счетчик никогда не достигнет нуля, поскольку страница теперь одно сообщение с цветных полос на фоне.

Ошибка 0x484558: сигнал за
ПЕРЕДАЧА ДАННЫХ ШИФРУЕТСЯ, ВНЕ ДИАПАЗОНА ИЛИ В АВТОНОМНОМ РЕЖИМЕ

0x484558 решает 'наговор' с с HEX в ASCII конвертор ... ( как ранее 0x575341 --> ВСС )

Помните, все в источниках : в RGB(74, 46, 109) и RGB(112, 47, 97) в RGB(101, 114, 111) в RGB(115, 112, 97) в RGB(99, 101, 114)

Из ASCII в текст 074 046 109 112 047 097 101 114 111 115 112 097 099 101 114 дает что-то вроде Дж. Мп/aerospacer

Просто заполните Дж. Мп/aerospacer в Firefox панель навигации ( не в поисковой строке) и он разрешает http://soundcloud.com/worldspaceagency/02-traveler/s-lrAhQ

Дж. Мп/6EQUJ5-это тоже прыжок код http://en.wikipedia.org/wiki/Wow_signal

СИГНАЛ НАЙДЕН. Переподключения...

Вау ;-)

ПЕРЕПОДКЛЮЧЕНИЕ ПОЛНОЙ. ПЕРЕДАЧА ЗАХВАТ 
РАСЧЕТНОЕ ВРЕМЯ ЗАВЕРШЕНИЯ 2011-10-12 04:00Z

Проверяем исходный код для защищенных паролем файлов данных :

В исходном ИРЦ ссылка была на самом деле связана с http://thisisthecountdown.com/wsa-server-rip/EXTRACTED-CASEFILES-r1.7z

Коды в RGB были слишком разные : В ASCII (097 108 105 101 110 114 105 102 116 102 114 111 110 ) = alienriftfron.. ( последние цифры были 0 0 за один час до начала новый отсчет)... анаграмма finalfrontier (пароль)

Заголовок страницы был [email protected]: расшифровка...

Потом пришел новый отсчет .... читай первый пост за всю историю.

Похоже, что файлы не похож на другие мы можем получить доступ через SSH

Логотип Ubuntu теперь в передней части страница...

данные-текст="целый новый мир. Совершенно новый компьютер. #Убунту"

Долго Онейроидного жизни... Спасибо за классную музыку ;-)

+452
kaskader 23 янв. 2019 г., 1:57:10

Использовать различные профили. Запустить Firefox в качестве

в Firefox -ProfileManager -нет-пульт дистанционного

чтобы получить менеджера профилей.

+320
013cijntje 4 мар. 2013 г., 17:26:22

Мне кажется, что вы уже получаете высокую скорость в определенное время для любой другой операционной системы, вы пробовали на свой компьютер. Скачивание Ubuntu не будет автоматически ускорить скорость вашего интернета; этой услуги определяется вашим интернет-провайдером (ISP). Я бы рекомендовал двигаться как можно ближе к беспроводной точке доступа, как это возможно, или даже, используя Ethernet-кабель, если это не слишком много хлопот.

Одним из возможных (но это догадка) явно медленнее, заключается в том, что Убунту может обновить текущую скорость загрузки более часто, но нет ничего в Убунту, которая может замедлить скорость загрузки. Это скорее всего аппаратная проблема, либо связанные с вашей силой сигнала, тип памяти, где скачать сохранения, или объем памяти, выделенный для Ubuntu запускать.

+297
user19868 30 июн. 2012 г., 14:52:51

Для печати в черно-белых тонах только продублируйте ваш Оригинальный принтер и переименовать новую что-то вроде "MG5250-черно-белый". Затем, в свойствах->"параметры задания"->"прочие настройки (расширенный"), добавить опцию "CNGrayscale" и измените значение на "True".

Затем, когда вы хотите напечатать черно-белые (оттенки серого), просто выберите этот принтер вместо. Я установить его в качестве принтера по умолчанию, поскольку B&W-это то, что я печатаю в основном.

+271
llamalover2204 13 апр. 2013 г., 19:20:27

Это помогло бы знать точно , что вы хотите сделать, но вы можете определенно сделать это. Узнав о Баш параметр расширения , вероятно, довольно надо.

В зависимости от того, что вы что делать, вам может потребоваться отдельная расширением и именем, а может и нет.

Я полагаю у тебя уже кдЭД в папку с файлами в вопрос.

случай 1: Предположим, что вы хотите изменить строку "плохого" к "хорошему" в каждый файл название, затем вы можете использовать простой подстановки, т. е. вы можете сделать что-то вроде:

для файл в * ; файл Сделать МВ "$" "${файл//Плохой/хороший}" ; сделано

(Убедитесь, что нет никаких изменений, что изменение к лучшему будет перезаписать что-то уже есть.) Это сработает независимо от расширения.

случай 2: Suppse вам нужно добавить "новый" перед расширением, что бы это ни было, тогда вы можете сделать:

для файл В * ; делать именем="${файл%.*}" ; расширение="${файл##*.}" ; файл MV "$" "${имя}нов.${расширение}" ; сделано

Расширение останется прежним, как бы то ни было.

Я бы дал больше советов, но опять же, я действительно не знаю, что ты пытаешься сделать, точно.

+258
OniGrimm 30 авг. 2019 г., 11:24:31

Я столкнулся некоторые проблемы с веб-камеры в Skype и других программ в прошлом, который может быть прочитан в следующие форумы:

http://forumubuntusoftware.info/viewtopic.php?f=66&t=4998&start=0

Я пробовал (успешно) проект "Flashcam", которые очень хорошо документированы на официальном сайте по адресу:

http://www.swift-tools.net/Flashcam/

Это может помочь.

+257
Joel Vanilla 13 июл. 2014 г., 22:52:24

Я не знаю, есть ли это в старых версиях, но в Thunar 1.6.3, по крайней мере, вы можете держать нажатой клавишу Ctrl и щелкните правой кнопкой мыши файл, который не выбран, и вы получите контекстное меню справочника.

+254
chourobin 6 дек. 2016 г., 6:18:30

Проблема с ваш скрипт, что Су $пользователей линия вызывает подуровень, и поэтому следующая команда не выполняется, пока что subshell-это выход.

Вы, наверное, хотите сделать что-то более похожее:

Пользователь=sameek
USERCMDS=/tmp/и usercommands.$$
Эхо "переменной JAVA_HOME=..." >>$USERCMDS
Эхо "путь=\${переменной JAVA_HOME}:\$путь" >> $USERCMDS
эхо "и javac HelloWorld.java" >> $USERCMDS
команду chmod а+х $USERCMDS
пользователь-C Су $$USERCMDS
+211
bururozu 26 дек. 2017 г., 21:55:35

Ну как говорит название, я не могу использовать Wubi с 32-разрядной версии Windows, он выдает ошибку. Есть ли исправить?

+197
Alligator22 11 нояб. 2014 г., 15:51:51

Показать вопросы с тегом